7.0.1

7.0.0

Adds support for Swift 4.2 and Xcode 10.

6.0.1

Adds support for Swift 4.1 and Xcode 9.3 (tested with beta 4).

6.0.0

Adds support for Swift 4 and Xcode 9

5.2.0

Adds support for Swift 3.1 and Xcode 8.3

5.0.0

Adds support for Swift 3 and Xcode 8

4.1.1

Adds support for Swift 2.3 and Xcode 8 (tested with beta 4)

4.1.0

4.0.0

BrightFutures 4.0.0 is compatible with Swift 2.2 and Xcode 7.3.

3.3.0

Note: some versions are missing here

3.0.0-beta.4

2.0.1

3.0.0-beta.1

This release is compatible with Swift 2. It is a direct port of 2.0, meaning it makes no use of new Swift 2 features yet.

Because antitypical/Result has not yet released a Swift 2 compatible release on CocoaPods, this version of BrightFutures can not yet be built using CocoaPods.

2.0.0

1.0.1

1.0.0

1.0.0-beta.3

Note: The overview for this release is incomplete

1.0.0-beta.2

Note: this overview is incomplete

1.0.0-beta.1

This release marks the state of the project before this changelog was kept up to date.